Jump to content


Photo

Water return line leak


  • Please log in to reply
3 replies to this topic

#1 mikeski

mikeski

    Member

  • Members
  • PipPip
  • 17 posts
  • LocationGeorgia

Posted 21 February 2015 - 04:13 PM

I just installed a new Filstar xp m and i can't stop the water from leaking at the tank end return fitting.

I have taken it apart and reinstalled it.

 

I secured it with the factory clamp and an adjustable hose clamp and it still leaks.

 

I'm afraid to tighten to much on the clamp for fear of breaking or distorting the plastic pipe.

 

Has anyone run into this problem before? if so what was the fix?

 

I am thinking about making my own out of 1/2" cpvc.

 

Mike

 

 

 



#2 LDick

LDick

    Chairman, BOD

  • ALA Members
  • 93 posts

Posted 21 February 2015 - 07:46 PM

Hi Mike,  have you tried Googling for possible reasons and fixes?  What about trying to contact Rena?

 

Hope you fix this leak - filter leaks are no fun :(

 

Best Fishes,

Leslie



#3 mikeski

mikeski

    Member

  • Members
  • PipPip
  • 17 posts
  • LocationGeorgia

Posted 21 February 2015 - 10:20 PM

Leslie

 

Well I took a chance and tightened up and then tightened up and tightened up some more on the clamp and somehow it seems to have finally stopped the leak! I'm amazed that flimsy piece of plastic tubing took the strain!

 

I did google and found nothing, but that doesn't mean it's not out there somewhere.

 

Thanks

 

Mike



#4 LDick

LDick

    Chairman, BOD

  • ALA Members
  • 93 posts

Posted 22 February 2015 - 08:47 PM

Good news, Mike!

 

Best Fishes,

Leslie






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users